Multiple DAC and Management Console Issues

Incident Report for Satori

Resolved

This incident has been resolved. Customers who are still experiencing issues should open a support ticket. Clearing the browser or workstation DNS cache is recommended for users who still experience issues.
Posted Sep 25, 2025 - 17:21 UTC

Update

We see improvement in global DNS propagation. Customers who are still experiencing issues should open a support ticket.
Posted Sep 25, 2025 - 07:27 UTC

Update

We have confirmed that all systems and services are operational. However, some users still get stale DNS entries due to caching. Clearing local DNS caches may help resolve the issue; however, some DNS caching occurs at layers beyond users' workstations which prolong the impact of the incident.

The team is monitoring global DNS propagation and confims some regions are still impacted.
Posted Sep 24, 2025 - 16:31 UTC

Update

All services have been restored, however, several users still report an issue resolving Satori domain names. This indicates to DNS updates propagation that may take some time to complete. Users can clear their DNS cache to try and speed up the process.
Posted Sep 24, 2025 - 13:42 UTC

Monitoring

We have implemented a fix and are monitoring the results. Some services are up.
Posted Sep 24, 2025 - 13:34 UTC

Update

We are now focused on a DNS registrar issue. We will send an additional update in an hour.
Posted Sep 24, 2025 - 11:52 UTC

Identified

The issue is likely related to an outage in Google DNS, which is used by Satori services. We are working to identify the scope of the outage and considering failing over to an alternative DNS service.
Posted Sep 24, 2025 - 10:57 UTC

Update

We are continuing to investigate this issue.
Posted Sep 24, 2025 - 10:28 UTC

Investigating

Our monitoring systems have detected several failures in DACs and the Management Console.
Posted Sep 24, 2025 - 10:26 UTC
This incident affected: Management Console, Satori DAC AWS us-east-1 (N. Virginia), Satori DAC AWS us-west-2 (Oregon), Satori DAC AWS eu-central-1 (Frankfurt), Satori DAC AWS eu-west-1 (Ireland), Satori DAC GCP eu-west2 (London), Satori DAC GCP us-east1 (S. Carolina), Satori DAC AWS ap-southeast-1 (Singapore), Satori DAC Azure eastus-2 (Virginia), and Customer Hosted DAC.