Issue Connecting to Snowflake

Incident Report for Satori

Resolved

The issue has been resolved for Satori SaaS customers and customers who have upgraded to v1.2614.3 or v1.2613.4.
Posted Apr 01, 2026 - 08:21 UTC

Monitoring

A fix has been implemented for Satori SaaS customers with no reported impact on customer Snowflake accounts. Customers with customer-hosted DACs should deploy release v.1.2614.3 immediately to mitigate the issue.
Posted Apr 01, 2026 - 07:42 UTC

Identified

We have identified the root cause of the issue and are preparing a fix. Customers using customer-hosted DACs will receive a notification to upgrade their DACs shortly.
Posted Apr 01, 2026 - 05:06 UTC

Investigating

Our monitoring systems have detected an issue connecting to Snowfalke via the Satori proxy in some regions.
Posted Apr 01, 2026 - 04:40 UTC
This incident affected: Satori DAC AWS us-east-1 (N. Virginia), Satori DAC AWS us-west-2 (Oregon), Satori DAC AWS eu-central-1 (Frankfurt), Satori DAC AWS eu-west-1 (Ireland), and Satori DAC Azure eastus-2 (Virginia).