Dynamic Masking Issue in Snowflake Workspaces

Incident Report for Satori

Resolved

The incident is resolved. Customers hosting their own DACs should upgrade to version 1.2615.2 to mitigate the issue.
Posted Apr 15, 2026 - 17:48 UTC

Monitoring

A fix has been rolled out to all SaaS DACs. Customers hosting their own DACs should upgrade to version 1.2615.2.
Posted Apr 15, 2026 - 15:27 UTC

Identified

Our monitoring systems have detected a change in Snowflake that impacts dynamic masking functionality in Snowsight Workspaces in some regions. A fix has been rolled out to all SaaS DACs. Customers hosting their own DACs should upgrade to version 1.2615.2.
Posted Apr 15, 2026 - 14:43 UTC
This incident affected: Customer Hosted DAC.