Workspaces Not Loading for Snowflake Proxy Accounts

Incident Report for Satori

Resolved

A fix has been deployed to all SaaS DACs. Customers with customer-hosted DACs should upgrade to v1.2621.2.
Posted May 20, 2026 - 12:43 UTC

Monitoring

A fix has been deployed to all SaaS DACs. Customers with customer-hosted DACs should upgrade to v1.2621.2.
Posted May 20, 2026 - 09:59 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted May 20, 2026 - 07:17 UTC

Investigating

Our monitoring system has detected a change in Snowflake that impacts the availability of Snowflake Workspaces in Snowsight in some regions, in Snowflake Proxy Accounts.

A fix for the issue is being prepared. We will update once a patch is available for customer-hosted DACs.
Posted May 20, 2026 - 06:28 UTC
This incident affected: Satori DAC AWS us-east-1 (N. Virginia), Satori DAC AWS us-west-2 (Oregon), Satori DAC AWS eu-central-1 (Frankfurt), Satori DAC AWS ap-southeast-1 (Singapore), and Customer Hosted DAC.